新人下载app,立即提现现金 您的好友 送你现金 去提现

ROS的小包优先QOS限速,24小时挂PT都不怕卡了

coraloneee 08-06 11:20 关注

家里升级到千兆网络,顺便把上行开到了200Mbps,想着下行1000Mbps,上行200Mbps的网络,应该完全不需要开限速了吧,结果最近PT+qbitorrent搞上传,差点把网络搞趴下。。。

其实这篇文章的限速也蛮有用的https://post.smzdm.com/p/415570/,用的是PCQ限速,当整个网络突破设置的限速时,带宽均分,但是qb是安装在synology的docker中的,而synology是整个网络核心,一旦qb上传满速时,整个synology就龟速了,解决方法倒也不是没有,可以把qb分出去,新虚拟个win或者ubuntu,但是种子那么多,懒得迁移,所以翻了下各位大神整理的,期间碰到点小坑,P2P的识别ROS在6.X的某个版本中就没有了,尝试了几个脚本都不怎么给力,于是想到了端口标记来做

下面是代码,很简单

/queue tree

add comment="D0A1B0FCD3C5CFC8" limit-at=10M max-limit=190M name=p2p1 packet-mark=P2p parent=pppoe-out1 queue=default

add comment="D0A1B0FCD3C5CFC8" name=ClassA parent=global priority=7 queue=default

add name=ClassB parent=ClassA queue=default

add name=Leaf1 packet-mark=General parent=ClassA priority=7 queue=default

add name=Leaf2 packet-mark=Small parent=ClassB priority=3 queue=default

add name=Leaf4 packet-mark=Small_Big parent=ClassB priority=5 queue=default

add name=Leaf5 packet-mark=Big parent=ClassB priority=6 queue=default

add name=Leaf3 packet-mark=Tcp parent=ClassB priority=4 queue=default

/ip firewall mangle

add action=mark-packet chain=prerouting comment="Mark packet for QoS (download)" disabled=yes in-interface=pppoe-out1 new-packet-mark=pkt-download passthrough=yes

add action=mark-packet chain=prerouting comment="Mark packet for QoS (upload)" disabled=yes in-interface=lan new-packet-mark=pkt-upload passthrough=yes

add action=mark-packet chain=forward comment=General connection-mark=!P2p_conn new-packet-mark=General

add action=mark-packet chain=forward comment=Small new-packet-mark=Small packet-size=0-32

add action=mark-packet chain=forward new-packet-mark=Small protocol=icmp

add action=mark-packet chain=forward comment=Tcp dst-port=22,23,80,443 new-packet-mark=Tcp protocol=tcp

add action=mark-packet chain=forward comment=Small_Big new-packet-mark=Small_Big packet-size=33-512

add action=mark-packet chain=forward comment=Big new-packet-mark=Big packet-size=513-1200

add action=mark-connection chain=forward comment=p2p in-interface=all-ppp new-connection-mark=P2p_conn passthrough=yes port=7881 protocol=tcp

add action=mark-packet chain=forward connection-mark=P2p_conn new-packet-mark=P2p passthrough=no


其中把port=7881调整成你自己的qbittorent的端口号即可,记得把udp的关掉

ROS的小包优先QOS限速,24小时挂PT都不怕卡了

然后在queue tree中把p2p的最大限速调整成你上传带宽x0.9就可以愉快的玩耍了

另外下行的限速,这个7881的端口没有用,标记不到流量,下行的端口是乱七八糟的,也没搞懂,明明docker中只开了7881,结果下行全部是其他端口,于是索性不标记这个了,直接在qb中限速800Mbps也足够快了

展开阅读全文

查看更多好文内容,新用户限时领现金
全部评论 (1)
allenilkb
0
09-18 20:47

高手啊,先收藏了!

打开App,查看更多好文和评论
值得买爆款低价
双11爆款商品抄底,APP内抢购!
值得买爆款低价

市场价
值得买双11价
网络设备促销活动
促销攻略:京东 360网络设备旗舰店 双11预热促销专场
促销攻略:京东 360网络设备旗舰店 双11预热促销专场
价格直降,最高立省90元
京东 10-30
1 67%
最新网络设备优惠
MI 小米 AC2350 AloT 千兆路由器
MI 小米 AC2350 AloT 千兆路由器

独立的AloT通路 专为智能家居准备

199元包邮
小米有品 07:34
0 0
NETGEAR 网件 RAX200 AX11000M WiFi6路由器
NETGEAR 网件 RAX200 AX11000M WiFi6路由器

京东好评率98% 分期免息 | 12期

3799元包邮
京东 06:22
0 0
HUAWEI 华为 AX3 凌霄双核路由器 Wi-Fi 6
HUAWEI 华为 AX3 凌霄双核路由器 Wi-Fi 6

Wifi 6+ 千兆端口

189元包邮(黑卡最高可抵28.35元)
拼多多 02:19
0 0
MI 小米 AC2350 AloT 千兆路由器
MI 小米 AC2350 AloT 千兆路由器

性能强劲 高通芯片

199元包邮
苏宁易购 01:48
1 50%
查看更多
猜你喜欢
查看更多
相关好价
相关商品
查看更多热门商品
社区主页 文章详情
1
5
1
你已经点过赞了
新浪微博 QQ空间 微信好友 豆瓣
当前为触屏版
热门搜索