社区主页 文章详情

谁说中文不能编程了?快看文言文大战东北话

DigiHacker 02-10 09:57 关注


自从有了互联网,每个月都会有编程小白发贴问,可不可以用中文编程。虽然老遭鄙视,但情有可原,非科班出身的程序员,理解编程就很难了,再加上一直头痛的英语,更是难上加难。后来支持中文的易语言受到了很多人追捧,就是出于这个原因。但主流程序员还是不屑一顾。

可从去年年底,事情发生了变化。一种叫文言文编程语言(wenyan-lang/wenyan)在github上大火,到目前为止有1万4个star. 一段文雅的文言文

吾有一數。曰三。名之曰「甲」。 為是「甲」遍。 吾有一言。曰「「問天地好在。」」。書之。 云云。

等效于下面的JavaScript

var n = 3;

for (var i = 0; i < n; i++) {

console.log("問天地好在。");

}

同时还可以转换成Python和Ruby, 最重要的是图灵完备!但看了官方例程后,小编决定还是学好英语吧。

吾有一言。曰「「春日宴。」」。書之。 有數九。名之曰「酒數」。 恆為是。若「酒數」等於零者乃止也。 吾有三言。曰「「與君」」。曰「酒數」。 曰「「杯酒。可以窮歡宴。綠酒一杯歌一遍。」」。書之。 減「酒數」以一。昔之「酒數」者。今其是矣云云。 吾有一言。曰「「綠酒千杯腸已爛。」」。書之。

不能不说,用这个语言编程,很酷,但未免有点装。于是这两天,一门新的语言dongbei(github: zhanyong-wan/dongbei) 横空出世, 可以用东北话编程。它的Hello World是这样的

唠唠:“唉呀,这嘎哒真他妈那啥!”。

输出为

唉呀,这嘎哒真他妈那啥!

声明变量是这样的

老王装二

变量引用是这样的

老张是活雷锋。

老王是活雷锋。

老张装250。

老王装老张加13。

完整的九九表是这样的

写九九表咋整: # 定义套路 写九九表。

老王从1到9磨叽:

老张从老王到9磨叽:

唠唠:老王、“*”、老张、“=”、老王乘老张。 # 打印 X*Y=Z

磨叽完了。

唠唠:“”。 # 空一行。

磨叽完了。

整完了。 # 结束套路定义。

自从大年三十,春晚没把我逗笑,没想到看段代码把我快笑疯了。

翠花,上 re。 # 导入 python 的正则表达式 re 模块。

老王装“abd”。

寻思:整re.match(“a.*”,老王)? # 调用 re.match()。

要行咧就唠唠:“OK!”。

要不行咧就唠唠:“砸了!”。

稍带着看了下源代码,居然只有一个Python文件,只有1200多行,除了sys,os外只用了re这个正则表达式库。看来是把中文翻译成python表达式了,代码简洁标准规范,据说作者是来自Google,真是集实力与搞笑担当于一身的奇才啊

虽然有了文雅至极和接地气的两门中文语言,但还不能说中文编程语言的春天来了。毕竟世界上还有一大半程序员说的是英语,人类无法理解二进制,但起码能理解编程语言。而未来的编程语言应该是高效如C,易懂如Ruby,将开发速度与运行速度完美结合的语言。

当然了,现阶段最好的语言是PHP


未经授权,不得转载

展开阅读全文

打开App,查看更多好文内容

暂无评论,打开APP参与讨论

猜你喜欢
编辑精选
相关商品推荐
0
0
0
你已经点过赞了
新浪微博 QQ空间 微信好友 豆瓣
当前为触屏版
热门搜索